[cvs] / xvidcore / debian / rules Repository:
ViewVC logotype

Annotation of /xvidcore/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (view) (download)

1 : Isibaar 1.1 #!/usr/bin/make -f
2 :     # Sample debian/rules that uses debhelper.
3 :     # GNU copyright 1997 to 1999 by Joey Hess.
4 :    
5 :     # Uncomment this to turn on verbose mode.
6 :     #export DH_VERBOSE=1
7 :    
8 :     # These are used for cross-compiling and for saving the configure script
9 :     # from having to guess our platform (since we know it already)
10 :     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11 :     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
12 :    
13 :     # shared library versions, option 1
14 :     version=`ls $(CURDIR)/build/generic/=build/lib*.so.* | \
15 :     awk '{if (match($$0,/[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
16 :     major=`ls $(CURDIR)/build/generic/=build/lib*.so.* | \
17 :     awk '{if (match($$0,/[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}' | \
18 :     cut -d '.' -f 1`
19 :    
20 :     configure: configure-stamp
21 :     configure-stamp:
22 :     dh_testdir
23 :     # Add here commands to configure the package.
24 :     cd $(CURDIR)/build/generic/ && ./configure --host=$(DEB_HOST_GNU_TYPE) --target=$(DEB_BUILD_GNU_TYPE)
25 :    
26 :     touch configure-stamp
27 :    
28 :    
29 :     build: build-stamp
30 :     build-stamp: configure-stamp
31 :     dh_testdir
32 :    
33 :     # Add here commands to compile the package.
34 :     $(MAKE) -C build/generic/ clean all
35 :    
36 :     touch build-stamp
37 :    
38 :     clean:
39 :     dh_testdir
40 :     dh_testroot
41 :     rm -f build-stamp configure-stamp
42 :    
43 :     # Add here commands to clean up after the build process.
44 : Isibaar 1.2 [ ! -f build/generic/Makefile ] || $(MAKE) -C build/generic/ distclean
45 : Isibaar 1.1
46 :     dh_clean
47 :    
48 :     install: build
49 :     dh_testdir
50 :     dh_testroot
51 :     dh_clean -k
52 :     dh_installdirs
53 :    
54 :     # Add here commands to install the package into debian/tmp
55 :     $(MAKE) -C build/generic/ install prefix=$(CURDIR)/debian/tmp/usr
56 :    
57 :     # Build architecture-independent files here.
58 :     binary-indep: build install
59 :     # We have nothing to do by default.
60 :    
61 :     # Build architecture-dependent files here.
62 :     binary-arch: build install
63 :     dh_testdir -a
64 :     dh_testroot -a
65 :     dh_installchangelogs -a ChangeLog
66 :     dh_installdocs -a
67 :     dh_installexamples -a
68 :     dh_install -a
69 :     # dh_installmenu
70 :     # dh_installdebconf
71 :     # dh_installlogrotate
72 :     # dh_installemacsen
73 :     # dh_installpam
74 :     # dh_installmime
75 :     # dh_installinit
76 :     # dh_installcron
77 :     # dh_installinfo
78 :     # dh_installman
79 :     dh_link -plibxvidcore$(major) usr/lib/libxvidcore.so.$(version) usr/lib/libxvidcore.so.$(major)
80 :     dh_link -plibxvidcore$(major)-dev usr/lib/libxvidcore.so.$(version) usr/lib/libxvidcore.so
81 :     dh_strip -a
82 :     dh_compress -a
83 :     dh_fixperms -a
84 :     # dh_perl
85 :     # d_python
86 :     dh_makeshlibs -V
87 :     dh_installdeb -a
88 :     dh_shlibdeps -a
89 :     dh_gencontrol -a
90 :     dh_md5sums -a
91 :     dh_builddeb -a
92 :    
93 :     binary: binary-indep binary-arch
94 :     .PHONY: build clean binary-indep binary-arch binary install configure

No admin address has been configured
ViewVC Help
Powered by ViewVC 1.0.4